I Must Have Been Gone a Long Time….

because my garden is sooo overgrown and kind of broken. Well, after getting very busy, an ice storm or two, and the drought, and the heat and the drought and the heat. I must be crazy to try to garden again, and even crazier to try to make enough time to keep track of things here. Enough waffle, here’s what I did at the weekend:

Cleared out an area around the mailbox. Its roughly 250′ from the house so its a challenge to water, but I want a cheerful welcome when I come home and go get the mail. Besides, the mail box is kind of fugly so maybe a few flowers will distract attention from it.  Here’s my bare dirt and the first plants:

Mailbox Bed 052013

I have Indian Feather (pink), Lantana (pink/yellow), Mexican Marigold (yellow), Achillea (yellow), and Russian Sage (purple).  I added three bags of purchased dirt plus a wheelbarrow full of my own compost and now I’m laying out a soaker hose. (Wish me luck!)

 

Advertisements

Tags: , , , , , ,

2 Responses to “I Must Have Been Gone a Long Time….”

  1. susinok Says:

    It looks great, Chris!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: